Donation Pages Loading Slowly

Incident Report for Raisely

Resolved

This incident has been resolved.
Posted Dec 10, 2025 - 11:30 AEDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 10, 2025 - 11:16 AEDT

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 10, 2025 - 11:11 AEDT

Investigating

We have identified an issue where donation pages are loading slowly. Users may experience delays of up to 2 minutes for the donation form to load.
We are actively investigating the issue.
Posted Dec 10, 2025 - 10:20 AEDT
This incident affected: Donation & Payment Processing.