Issues with adding new custom email sending domains

Incident Report for Raisely

Resolved

This incident has been resolved.
Posted Jun 12, 2024 - 01:47 AEST

Identified

We are currently working on resolving an issue with adding new custom email sending domains.
This does not impact existing email domains.
Posted Jun 11, 2024 - 03:01 AEST