A fix has been implemented and we are monitoring the results.
Posted Dec 10, 2025 - 12:20 AEDT
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 10, 2025 - 12:19 AEDT
Investigating
We have identified an issue where there are intermittent delays in processing donation events after payments are completed, affecting some downstream webhooks. Donations are processing successfully and payments are being recorded. The engineering team are actively investigating the issue.
Posted Dec 10, 2025 - 09:47 AEDT
This incident affected: Donation & Payment Processing.